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Purpose 
To provide an introduction to the Interaction Client Business Manager (ICBM) software application. 

Introduction 
Interaction Business Manager (ICBM): 

• provides Call Queue Supervisors with a user interface for easy access to display real-time 
performance monitoring of Call Queues 

• sends out notifications when user-defined thresholds are reached 
• allows users to access various ‘views’- presented in statistics, graphs, queue and reports 
• provides users with a workspace where views can be organised (including views from 

different application modules) 
 

How Do I Access Business Manager? 
A license must be purchased to use ICBM. 
 
To obtain access to ICBM, log a call with the CSU IT Service Desk (providing an account code).  
 
You can contact the Service Desk either by calling x84357 or Online Self Service.  
 

Getting Started 
To get started using ICBM, you must open ICBM on your desktop. There are two ways to open 
ICBM: 

 
1. Double-click the IC Business Manager icon that appears on your desktop (this will 

remember your last login settings); or 
 

 
 

2. Click Start > All Programs > Interactive Intelligence > IC Business Manager (this does not 
remember your last login settings). 

 
Whether you double click the icon or access ICBM through your Start Menu, you will see the ICBM 
login screen: 

 
1. Under the Options Tab, change the Language from English (United States) to English (Australia) 

(This change will have to be changed this every time you login until a patch is released to fix) 

http://www.csu.edu.au/division/dit/services/
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2. Under the Connection Tab, Click Use Windows Authentication tick box  
3. Enter your CSU credentials into the User and Password boxes, and then enter the server 

address of ic.csu.edu.au and click Log On.  
  

 

You will be presented with the window below: 
 

 

When IC Business Manager loads, you have two tabs on the left hand side of the screen (Default 
Workspace and Interaction Reporter). 
 
You can add additional workspaces by going to the top of the screen and clicking Workspace > 
Create workspace. 

Default 
Workspace 

Interaction 
Reporter 
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The above box will pop up.  

3. Enter a Name and Description as required, select a meaningful Icon for the Workspace (e.g. 
graph icon for statistics) and click OK. This will add an extra workspace to the left hand side 
of your screen 

4. You can now add agent and queue information to your workspaces.  
 

There are multiple ways to add a view to your workspace. 

• Option 1 - Click File > New > View… 
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• Option 2 – In a new workspace, you’ll see the Getting Started page. Click View 

 

 
 

• Option 3 – Click New > View… 
 

 

Once you select a new view, you will be presented with the following screen: 
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Agent Details  
This view gives statistics for a specific agent for a specified Workgroup: 

1. In the top filter text box, you can search for an Agent (Last name, First name) 
2. When found, select the agent and click Next 

 

  

3. Workgroups that the selected agent is a member will display in list format: 
 

 

4. Select the workgroup you wish to see the details of and click Finish. 
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A new view will be created (Agent Details) with down boxes for Agent and Workgroup.  

You have the choice to either leave the page (for a specific user and a workgroup they are in) and 
create a new view per agent, or you can use this view to go to different agents as required. 

 

Agents Graph  
 This view shows a graph with specified visual statistics for multiple/singular agents: 

1. In the top filter text box, search for a Workgroup  
2. When found, select the workgroup and click Next 

 

 

3. Select the Agents you want to add to the graph (hold control (Ctrl) and click the Agent) and 
click Add (if you want all Agents in the Workgroup, click Add all) 

4. Click Next 
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By default, this graph selects Current Period, Current Shift, Previous Period and Previous Shift 
interval periods. You can select and remove the intervals you don’t need. 

5. Select the Queue Statistics you wish to see in the graph and click Add 
6. Click Finish 
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Bar Graph View 

 

You can edit the graph once saved: 

• Right click on the graph and select what you want to edit (e.g. graph types, interval periods, 
grouping etc.) 
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Agent or Workgroup Queue  
This view will give the current interaction detail(s) for users and workgroups: 

1. Select Agent or Workgroup view – you can alter the entries in the window shown below 
 

 

2. Choose the drop down menus which suits: 
 

• Queue Type – allows you to select Workgroup Queue information or User Queue 
information 

• Workgroup Queue – allows you to select the queue you wish to monitor (NOTE: this 
will alter Agent Queue if User Queue type is selected above). 

• Interaction Type – provides a list of different interactions to monitor 
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Agent Overview  
Provides the same information as the Agent Graph but in list view: 

1. In the top filter text box, search for a Workgroup 
2. When found, select the workgroup and click Next 

 

 

3. Select the Agents you want to add to the graph (hold control (Ctrl) and click the Agent) and 
click Add (if you want all Agents in the Workgroup, click Add all) 

4. Click Next 
 

By default, this graph selects Current Period, Current Shift, Previous Period and Previous Shift 
interval periods. You can select and remove the intervals you don’t need. 

5. Select the Queue Statistics you wish to see in the graph and click Add 
6. Click Finish to see the requested information for each Agent. 
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Workgroup Details  
This view gives the majority of statistics for a singular queue in one view. You can also toggle 
between Queue calls and Queue members to see their activation. 

1. In the filter section (top left of the view), select the queue you wish to monitor 
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2. Select either Queue and Members (tabs on the left hand side of the screen) for further 
details: 

• Queue – shows all current calls for the Workgroup 
• Members – show the agents in the Workgroup with details (e.g. status and queue 

activation) 
 

 

 

Workgroup Directory  
The Workgroup Directory view shows the same details in the Members tab (as appears in the 
Workgroup Details view). 

 

Workgroup Graph 
Search using the filter for the Queue(s) you wish to appear in the graph: 

1. Select required queue and click Add 
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2. Select that statistics you want to appear in your graph 
3. Click Add 
4. Click Finish 

 

 

A bar graph will be generated by default. You also have the ability to change the types of 
information displayed (see Agents Graph). 
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Workgroup Overview   
Provides you with the same information as the Workgroup Graph but in list view: 

 

Workgroup Statistics  
This view gives you the top half of the Workgroup Details view.  

Statistics will appear for a particular queue once selected. 

 

 

You have the ability to add and remove statistics. 

 

 

Right Click inside the 
Workgroup/Queue 
Statistics field and 
select Add/Remove 
statistics. This will 
open a window where 
you can add/remove 
statists as required 
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Reporting 
There are two methods of reporting: 

• Interaction Reporter (inbuilt workspace) 
• Historical Reports (manual report view) 

 

 

Both of these options can be exported by clicking to Excel, PDF etc. and used as required. 

You can also save reports and re-run as desired. 

 

Interaction Reporter 
Each workspace has a number of inbuilt reports that you can select and change as required.  

Each report has a specific purpose and is fairly rigid in terms of the data it returns but is consistent 
and easy to use. 

For each report you will need to define a time frame and often a parameter.  

Each report will have a REQUIRED PARAMETER and an ADDITIONAL PARAMETERS section, these 
will change depending on the report you are running. Each report will have a timeframe you will 
need to select and has the option to enter a specific area of focus (either in the required section or 
by adding an additional parameter). 
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There are preset options such as Yesterday, This Week, etc and you can enter a Custom value (date 
or time frame). 

 

Parameters 

If it is required or additional, you can select several different types of information depending on the 
report as well as how you would like the report to obtain the information. You will need to highlight 
searches in inverted commas.  

For example “Queue-IT Service Desk”  If you do not add this, the report will not recognise this and 
will give you incorrect data.  

 

To Run a New Report: 

1. Select the Interaction Reporter workgroup 
2. On the left hand side of the screen, you will see a column with grouped entries. Hover over 

an item to see a summary of the report 
3. Double click the report you want to run and enter your information (see timeframe and 

parameters as above)  when prompted 
NOTE: Ensure parameter searches have “ “  

4. Click  
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Historical Reports 
This view allows you to create custom reports.  

It is highly customisable (different options, multiple pieces of information in a singular report) but 
more difficult to create than inbuilt reports.  

NOTE: You can run old saved reports from the previous version of Interaction Supervisor. 

To create a custom report: 

1. Click New > Historical Report 
2. Depending on the report you would like to create, select Available Packages and Layout 

(Table or Matrix) of the report 
3. Click Next 
4. Add Fields, Agents, Queues, Dates, Times etc. and then adjust to fit your purpose 
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Interaction Desktop 
As a Call Queue Supervisor, you will need access to both ICBM and Interaction Desktop.  You can 
monitor your workgroup and its statistics from within Interaction Desktop by adding your workgroup 
view.   

• Double-click the Interaction Desktop icon that appears on your desktop 

 
  

If you are unfamiliar with Interaction Desktop and the login process, please refer to the 
Interaction Desktop User Guide. 

 
 

Create the new workspace view 

• Right click anywhere within the My Interactions window and click on ‘New View’  
(or click on File > New > View) 
 

 

• In the Create New View dialog box, set Group by to Categories, and then from the list of 
categories, select Queues. 

• In the Views window select Workgroup Queue and click OK 
• Under Available items select the queue you wish to add.  

You can use the filter box at the top of the list to refine these results. 

mk:@MSITStore:C:%5CPROGRA%7E2%5CINTERA%7E1%5CICUSER%7E1%5CCLIENT%7E1.CHM::/Client_Pages_Dialog_Box.htm
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• Click Add and OK 

 
• The workgroup will appear as a new tab 

 
 
For additional views relevant to Business manager users please refer to the help guides in 
the next section. 
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IC Business Manager Help 
Further help can be found by selecting Help. 
 
A separate browser window displays the help topics along with Contents and Search navigation 
controls.  
 
 Help 
 

 
 
  

Access additional support articles from the Genesys support database 
Genesys Support Articles: Interaction Business Manager 

Or watch informational video’s from the Interaction Desktop playlist on youtube 
Genesys Demonstation Video's: Interaction Business Manager 

 
 
 
If you cannot find the help you need in these guides, please contact the IT Service Desk. 
 

https://help.genesys.com/cic/desktop/ic_business_manager_applications_landing.htm
https://www.youtube.com/playlist?list=PL4anLPM52HBD8iJPpQDqnTzDBz3dLAMn9
http://www.csu.edu.au/division/dit/services
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